[Dnssec-trigger] Dnssec-Trigger and MacOSX 10.8.3

Bry8 Star bry8star at inventati.org
Wed Sep 18 09:50:04 UTC 2013

Hi Wouter,


(Yes, the uninstall script was there, sorry for adding request on
that too quickly).

Earlier i used unbound from homebrew, on another apple-mac, that
worked fine as expected.

But if i could disable DnssecTrigger portion, and keep Unbound
running, then that would have been better.

I will request the user to let me have access to it for few more
days, and will enable debugging.

(Direct IP-address based connections are working fine).

Brand new Apple-Mac, just taken out of box.  DnssecTrigger was
installed as 6th, right after : (1) system update, (2) Firefox, (3)
Firefox extensions, (4) Microsoft Office, (5) Office update.

I think i also noticed such, few times after restart, in Firefox few
selective site worked/resolved for first few minutes, then they
stopped working.  Could it be, that, DnssecTrigger 1st starts to use
dns-result from some cache, and then DnssecTrigger may be switching
into another cache or another dns-resolver, and that 2nd cache is
empty or that another dns-resolver is inaccessible.  None of the
other/system apps was able to resolve dns after installing

Anyway needs more debugging.

Thanks again,
-- Bright Star.

Received from W.C.A. Wijngaards, on 2013-09-18 1:06 AM:
> Hi Bright Star,
> In the file you downloaded to install, the dmg, there is an uninstall
> script.  You can download the dmg again if you removed it.
> Doubleclick on the uninstall script and it uninstalls dnssec-trigger.
> If you want to use unbound without dnssec-trigger, perhaps you can use
> unbound from macports?
> On 09/18/2013 08:47 AM, Bry8 Star wrote:
>> Hi, dnssectrigger-0.11.dmg was installed on (a user's) MacOSX
>> 10.8.3. This Mac has Firefox. Firefox has two extensions : (1)
>> DNSSEC Validator, (2) Extended DNSSEC Validator. (1) is configured
>> to use CZ.NIC's/OARC's remote DNSSEC servers. (2) is configured to
>> use extension's own internal default DNSSEC server. (that is, i did
>> not specify any custom DNS-server in its DNS configuration box).
>> DnssecTrigger has changed system's default DNS settings and placed 
>> inside it, so Network Adapter's DNS settings now showing 
>> as DNS-Server.
>> Apps which use system's DNS settings, are not able to access 
>> internet sites.
> It should have worked, I wonder why, this would need debugging with
> setting verbosity in the dnssec-trigger.conf and unbound.conf higher
> and looking in the system logs.  But if you do not want to use it,
> then, the easiest is to manually compile and install unbound.
> Best regards,
>    Wouter
>> Visiting to any websites via Firefox has also stopped working.
>> I changed FF extension (1) and (2) settings both, and specified 
>> inside them, but did not work. (could not visit
>> websites, dns-resolving did not work).
>> When i changed system's DNS settings into local router's
>> IP-Address, for example,, then all started to work
>> back.
>> I want to disable DnssecTrigger portion only, and enable/use only 
>> "Unbound" resolver portion in Mac OSX, how do i do that ?  Since i 
>> want to disable DnssecTrigger portion, i also want to remove the 
>> DnssecTrigger icon from top bar.
>> And i also want to know how do i uninstall the full dnssectrigger 
>> package ?
>> Thanks in advance, -- Bright Star.
>> _______________________________________________ dnssec-trigger
>> mailing list dnssec-trigger at NLnetLabs.nl 
>> http://open.nlnetlabs.nl/mailman/listinfo/dnssec-trigger
> _______________________________________________
> dnssec-trigger mailing list
> dnssec-trigger at NLnetLabs.nl
> http://open.nlnetlabs.nl/mailman/listinfo/dnssec-trigger

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: OpenPGP digital signature
URL: <http://lists.nlnetlabs.nl/pipermail/dnssec-trigger/attachments/20130918/442ca758/attachment.bin>

More information about the dnssec-trigger mailing list