unbound dropping all queries with empty request list when used as a dns-over-tls forwarder

Mike Kazantsev mk.fraggod at gmail.com
Mon Apr 20 12:22:20 UTC 2020

On Mon, 20 Apr 2020 13:44:22 +0200
Renaud Allard <renaud at allard.it> wrote:

> On 4/20/20 12:16 PM, Mike Kazantsev via Unbound-users wrote:
> > 
> > I've tried setting up unbound for the first time (to replace existing
> > dns setup based around venerable djbdns), and seem to have stumbled
> > into following problem.
> > 
> > After as little as dozen minutes and as much as several hours, unbound
> > daemon stops responding to queries without any kind of overt errors
> > (e.g. warning/error-level logging) or indication that anything is abnormal.
> Could you try with "so-reuseport: no" to see if that improves the situation?

Thank you for suggestion.

Did enable it now, switching back to using Cloudflare directly.
Will report back if I'll see any issues or if it won't happen for a day
or so (as none of previous configurations worked that long).

Mike Kazantsev // fraggod.net

More information about the Unbound-users mailing list