Unbound 1.9.3 released

Yuri yvoinov at gmail.com
Fri Aug 30 17:36:14 UTC 2019

30.08.2019 13:52, Wouter Wijngaards via Unbound-users пишет:
> Hi Yuri,
> On 29/08/2019 09:43, Yuri via Unbound-users wrote:
>> Thank you, Jaco, but this not solves my problem.
>> I have Solaris 10u13 with Oracle Developer Studio 12.6 on SPARC-IV+ (so,
>> incompatible with Solaris 11.x).
>> 29.08.2019 13:29, Jaco Lesch via Unbound-users пишет:
>>> On 8/28/19 18:49, Yuri via Unbound-users wrote:
>>>> 28.08.2019 18:23, Wouter Wijngaards via Unbound-users пишет:
>>>>> Hi Yuri,
>>>>> On 27/08/2019 19:45, Yuri via Unbound-users wrote:
>>>>>> 27.08.2019 21:22, Yuri пишет:
>>>>>>> 27.08.2019 21:17, Wouter Wijngaards via Unbound-users пишет:
>>>>>>>> Hi Yuri,
>>>>>>>> If that is any similar to yours, the ./configure --disable-shared
>>>>>>>> flag
>>>>>>>> could fix it.
>>>>>> Tried with same error:
>>>>> It looks like the flag makes the library build pass, but this link
>>>>> fails
>>>>> because of (what may also be the first error) unrecognised options.
>>>>> Can you give the full commandline that failed, and also a couple before
>>>>> it (the libtool invocation, and then the compiler and linker lines).
>>>>> The flags on it, we can try to change them to see which one is the
>>>>> problem.  Something that looks like -...h... is what I guess from the
>>>>> link you sent.
>>>> Failed all object and binaries link call. Which one?
> The commandline I need is just before the part that you copy and pasted,
> and I guess about 20 lines more would help me.   That probably also
> includes another commandline before it, or even a non-failure line, but
> that's not a problem.
> Your configure options look nice.  The "--without-pthreads
> --with-solaris-threads" part should be okay, but on the CFLAGS there
> seems to be -pthread -mt.  This is weird.  The -pthread should not be
> there, I think.  Could you re-run configure, then when it is done edit
> the Makefile and remove the -pthread from the Makefile and see if that
> compiles?

Yes, this weird. Ever Dev Strudio accepts GCC options (most of all),
-pthread should be -lthread in LDFLAGS and -mt/-mt=yes in CFLAGS.

Sure, will play around with it.


"C++ seems like a language suitable for firing other people's legs."

* C++20 : Bug to the future *

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 659 bytes
Desc: OpenPGP digital signature
URL: <http://lists.nlnetlabs.nl/pipermail/unbound-users/attachments/20190830/f83ca4b1/attachment.bin>

More information about the Unbound-users mailing list