private ipv6 address space

Stephane Guedon stephane at
Tue Aug 1 08:16:52 UTC 2017

Good (insert your locale time of the day) all members of this list.

I have a trouble with my instance of Unbound (OpenBSD 6.1 stable) with private 
ipv6 space.

I have a local dns resolver/cache (Dnsmasq) which works perfect on my router. The 
Unbound instance is supposed to redirect all dns requests regarding private 
domains and address space to it:

private-address: fd00:2016:22::/48 

#domain-insecure: "" 

(In the begining - aka before two days ago - I used forward zones pointing at 
fd00:2016:22:dec::1 aka dnsmasq and the whole thing worked smoothly as 
intended. It does not anymore and I tried to upgrade my conf according to the 
manual and my understanding is that this conf' is supposed to be done with stub-

But apparently, whenever I send request on or I get blocked :

; <<>> DiG 9.4.2-P2 <<>> @unbound 

Can anyone tell me what mistake(s) I make ? Thank you in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: This is a digitally signed message part.
URL: <>

More information about the Unbound-users mailing list