[Unbound-users] error when threading enabled on local_unbound on FreeBSD 10.x

unbound at fongaboo.com unbound at fongaboo.com
Tue Jul 21 16:52:21 UTC 2015

Thanks... Sent me further down the right path (both literally and figuratively).

What I did was... I created a subdir /usr/local/etc/unbound/sbin

Then I added this to the top of the $PATH priority by editing .cshrc.

Then I made a bunch of symlinks from /usr/local/sbin/unbound-* to /usr/local/etc/unbound/sbin

This forced it such that when I run unbound-<whatever> from CLI anywhere, 
it defaults to the stock version and not the FreeBSD local_unbound 

For good measure, in case I ever want to run local_unbound for anything, I 
made a bunch more symlinks from /usr/sbin/unbound-* to /usr/local/etc/unbound/sbin/local_unbound-*

Hopefully this might be helpful to some FreeBSD users in the same situation...


On Tue, 21 Jul 2015, Jaap Akkerhuis wrote:

> unbound at fongaboo.com writes:
> >
> >
> > Thanks,
> >
> > I am now attempting to install from ports. However, am I gathering
> > correctly that FreeBSD's local_unbound's config files live in /etc/unbound
> > while stock unbound has them in /usr/local/etc/unbound?
> >
> Yes.
> > When I run unbound-control-setup, it seems to put the files it generates
> > in /etc/unbound anyway. What do I have to do to make sure everything
> > defaults to the stock setup instead of the local_unbound setup?
> Note your $PATH
> Make sure that you use the /usr/local/sbin/unbound-control-setup
> (and others from the ports). The /usr/sbin/$unboundtools have wired
> in the /etc as defaut path.
> Alternatively always usr the -f config with the build-in
> versions.
> 	jaap

More information about the Unbound-users mailing list