[Unbound-users] Resource temporarily unavailable and query problem with unbound

lst_hoe02 at kwsoft.de lst_hoe02 at kwsoft.de
Thu Nov 11 08:32:59 UTC 2010

Zitat von "W.C.A. Wijngaards" <wouter at NLnetLabs.nl>:

> Hash: SHA1
> Hi Sebastian,
> I am happy that you found a solution.
> On 11/10/2010 04:46 PM, Sebastian Nickel - Hetzner Online AG wrote:
>> I tried "netstat -su" and it showed me many UDP send buffer errors. So I
>> tried to set "net.core.wmem_max" to 8388608 (8m). It did not help.
> So it is the send buffer.
>> One last question:
>> If I use "so-rcvbuf: 8m" in unbound.conf does this only set the
>> appropiate kernel variables (like I did with sysctl) or is the value
>> "8m" used in some calculations inside unbounds code, too?
> No, it only uses the 8m to set a parameter on the socket itself (that
> overrides the kernel variable).
> Your sysctl values seem to be about setting the send buffer as well, and
> perhaps the socket parameter call for the send buffer could be useful;
> so that only that socket gets the large send buffer; not all of them (OK
> you have 12G :-) ).

I suspect doubling the "net.core.wmem_default" was the solution but  
this apply to all sockets without explicit settings, so a so-sndbuf  
setting would be useful.



More information about the Unbound-users mailing list