[Unbound-users] Unbound on Solaris 10

Hayward, Bruce Bruce.Hayward at mtsallstream.com
Tue Jul 20 18:38:22 UTC 2010

Note that I am aware of setting the LD_LIBRARY_PATH via say a .profile,
but was looking for a way to keep the compile separate from OS variables
- more looking to see if it can be added via a ./configure parameter.


Bruce Hayward, MTS Allstream Inc., (c) 204-792-9174 (p) 204-958-1983 (e)
bruce.hayward at mtsallstream.com 

-----Original Message-----
From: Hayward, Bruce 
Sent: July 20, 2010 12:47 PM
To: 'unbound-users at unbound.net'
Subject: RE: [Unbound-users] Unbound on Solaris 10 (Sparc) learning

Still learning:

I have now configured unbound with several options successfully with and
without threads (solaris et al). (gmake and gmake install ...)

This last time I tried without threads, but with libevents using:
./configure --prefix=/opt/unbound --libexecdir=/opt/unbound/lib
--sysconfdir=/var/unbound/etc --sharedstatedir=/var/unbound
--with-run-dir=/var/unbound --with-chroot-dir=/var/unbound
--with-pidfile=/var/unbound/run/unbound.pid --with-username=unbound
--with-ssl=/usr/local/ssl/ --without-pthreads --without-solaris-threads

This seems to work though I see:
libtool: link: warning: library
`/usr/local/libevent-1.4.13-stable//lib/libevent.la' was moved.
libtool: link: warning: library
`/usr/local/libevent-1.4.13-stable//lib/libevent.la' was moved.

Along with the gmake output.

Afterwhich I run a gmake install without incident.

I have also created a Solaris manifest (SMF), and are using that to
start/stop unbound, again successfully.

Unbound resolves correctly at this point.

Also for generating the remote keys:

root at wnpgmb024rw-ns05# unbound-control-setup
setup in directory /var/unbound
unbound_server.key exists
unbound_control.key exists
create unbound_server.pem (self signed certificate)
create unbound_control.pem (signed client certificate)
Signature ok
Getting CA Private Key
Setup success. Certificates created. Enable in unbound.conf file to use

However when running:
root at wnpgmb024rw-ns05# unbound-checkconf
ld.so.1: unbound-checkconf: fatal: libgcc_s.so.1: open failed: No such
file or directory
root at wnpgmb024rw-ns05

I have:
root at wnpgmb024rw-ns05# find / -name libgcc_s.so.1

Thoughts on the open failed? (I also get the same results using the MnM
pre-compiled version)



Bruce Hayward, MTS Allstream Inc., (c) 204-792-9174 (p) 204-958-1983 (e)
bruce.hayward at mtsallstream.com 

Is it really necessary to print this email?
MTS ALLSTREAM INC. CONFIDENTIALITY WARNING: This email message is confidential and intended only for the named recipient(s).  If you are not the intended recipient, or an agent responsible for delivering it to the intended recipient, or if this message has been sent to you in error, you are hereby notified that any review, use, dissemination, distribution or copying of this message or its contents is strictly prohibited.   If you have received this message in error, please notify the sender immediately and delete the original message.  If there is an agreement attached with this message, such agreement will not be binding until it is signed by all parties named therein.

More information about the Unbound-users mailing list