[Unbound-users] No answers from unbound occasionally

W.C.A. Wijngaards wouter at NLnetLabs.nl
Fri May 29 15:50:11 UTC 2009

Hash: SHA1

Hi Attila,

Are those replies from authority servers? That arrive just after unbound
times out and closes the socket?

Some sort of selective verbose logging is an idea on my TODO.

Unbound will indeed not respond to particular queries.  These queries
end up getting counted as 'cache hits', but really they were malformed.
 Some malformed queries unbound does not reply to - such as queries with
QR=1 flag, or shorter than 12 byte queries.  Since you are sending them
yourself, it seems unlikely they are this malformed.

Attila Nagy wrote:
> FreeBSD 7-STABLE, unbound r1584, single threaded.
> It seems that occasionally it does not answer (or just doesn't receive,
> I don't know) the queries.
> With tcpdump it seems that the machine gets the query, but there is no
> answer from unbound.
> Its statistics counters seems OK, there is no full queue, or drops
> according to that.

Is it a query to port 53?  Queries to other ports are not answered.

Are there 'jostled' queries? They also create dropped replies by
replacing an existing (old) one.

>    72146984 dropped due to full socket buffers

Could this explain the 1 in 100qps-for-3600s that are dropped?  Could
they be dropped at the query-sender (seems unlikely)?

> I've already tried to raise the related sysctls, without any effects.

You tried to increase socket buffers already, I presume. Weird.

Best regards,

Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the Unbound-users mailing list