[nsd-users] FreeBSD: mmap errors

Dustin Marquess dmarquess at gmail.com
Mon Jul 10 00:09:47 UTC 2017

I'm hoping somebody has seen this before, as I'm trying to nail down
which change caused this.  My old setup was stable.  I ended up doing
3 things:

- Moved from vanilla FreeBSD to HardenedBSD
- Added a slave server
- Moved nsd from to a virtual IP because of the slave server
(unbound is on the 'main' IP)

Everything works for a while, and then both the master and slave
eventually die with the same error (but not exactly at the same time):

Jul  6 06:59:14 xxx nsd[93796]:
mmap(/tmp/nsd-xfr-93796/nsd.93796.task.0, size 576) error Invalid
Jul  6 06:59:14 xxx nsd[93796]: tasklist: out of space, cannot add applyxfr
Jul  6 06:59:14 xxx nsd[27023]: signal received, shutting down...
Jul  6 06:59:14 xxx kernel: [791683] pid 93796 (nsd), uid 216: exited
on signal 11

I guessed maybe it was the memorylocked setting in /etc/login.conf, so
I tried doubling that, but that didn't seem to do it.  Any ideas?


More information about the nsd-users mailing list