[nsd-users] nsd can't bind udp socket: Address already in use

zongo saiba zongosaiba at gmail.com
Wed Jul 10 10:10:44 UTC 2013

On 10/07/2013 12:04, Anand Buddhdev wrote:
> On 10/07/2013 11:45, zongo saiba wrote:
> Hi Zongo,
>> So I understand that 127.0.01 is just booked by other processes and in
>> particular unbound.
>> What troubles me is how to solve that issue ?
> You can't have two different processes bound to the same address+port
> combination.
> You need to configure Unbound and NSD to listen on different ports,
> depending on what you are trying to achieve with your setup.
> Regards,
> Anand

Sorry i forgot to mention that NSD is listening on port 5353
Unbound is listening 53.
One of my main goal is to have unbound talk directly to NSD for 
authoritative server on only.
For that I understood that unbound and NSD would have to use the same 
port - Is this correct ?
Nevertheless, i tried the same port "53" but got same error message as 
mentioned above>


zongo saiba

More information about the nsd-users mailing list