[Dnssec-trigger] libgcc_s_sjlj-1.dll

Carsten Strotmann carsten at strotmann.de
Tue Jul 4 13:48:34 UTC 2017

Hello Wouter,
Hello List,

On 27.03.17 10:56 PM, Jeremy Rand wrote:
> wouter at nlnetlabs.nl (W.C.A. Wijngaards):
>> Hi Ales,
>> On 13/01/17 16:02, Ales Casar wrote:
>>> Hello!
>>> I have tried to install dnssec-trigger 0.13 on Windows Vista x64. 
>>> Unfortunately with no success. Many (all?) .exe binaries crashed
>>> during setup without any useful message. After some research of
>>> EventLog and manual testing I think the problem is in missing
>>> libgcc_s_sjlj-1.dll library. Then I've tried the same manual tests
>>> also with previous version of dnssec-trigger 0.12, and there was no
>>> such problems.
>>> Did perhaps maintainer of dnssec-trigger windows packages forgot
>>> to include libgcc_s_sjlj-1.dll library into the package? Or should
>>> I install some dependency before? If yes, which one? Or something 
>>> completely different?
>> Yes the dependencies seem to have changed between the versions, here
>> is a link to the package with the dll you refer to and
>> libwinpthread-1.dll.
>> www.nlnetlabs.nl/~wouter/dnssec_trigger_setup_0.14_20170106_2.exe
>> Best regards, Wouter
> Hi Wouter,
> Will this fixed version be posted on the main Dnssec-Trigger website?
> This would be useful for verifying its authenticity (e.g. via hashes
> posted on the main website).
> Cheers,
> -Jeremy Rand

I've run into the very same issue today while installing dnssec-trigger
on a Win7 machine.

Would it be possible to make a new release of dnssec-trigger, possibly
also including an updated Unbound (1.6.4) that includes the new Root-DNS
KSK trust anchor?



More information about the dnssec-trigger mailing list